Featured image of post MySQL起動時の「/etc/sysconfig/network: No such file」の対処【Docker】

MySQL起動時の「/etc/sysconfig/network: No such file」の対処【Docker】

DockerコンテナにインストールしたMySQLを起動すると「/etc/sysconfig/network: No such file or directory」が出て起動できないときの対処法。コンテナに入ってnetworkファイルを作成するだけで解決します♪

399文字

以下のようなエラーが。。。

DockerコンテナMySQLをインンストールし、いざ起動をしようとすると以下のようなエラーが発生して起動出来ない事があると思います。

Error Log
/etc/init.d/mysqld: line 23: /etc/sysconfig/network: No such file or directory

ムムム。。。

原因

これは/etc/sysconfig/networkというファイルが存在しないことが原因ぽいです。

詳しい原因まではわかりませんが、Dockerコンテナを利用するとデフォルトでは上記のファイルは存在しないのですが、mysqlの起動にはこのファイルが必須らしいです。

対応

なので、以下のコマンドでDockerコンテナに入り、

command
docker exec -it {Dockerコンテナ名} bash

以下のコマンドでnetworkファイルを作成しましょう。

command
echo "NETWORKING=yes" >/etc/sysconfig/network

これでMySQLの起動は正常に完了しました。

些細なことですが、知っていないとハマってしまう恐れのあるポイントですので、Dockerを使っているのであれば知っておくと良いでしょう♪